Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 02, 2026 - 09:00 UTC
Scheduled
During the scheduled maintenance we’ll perform upgrades on our user account system. This might briefly delay the synchronization of organization and member accounts between DRMtoday and the main Castlabs hub portal.
Core DRMtoday services such as license delivery, key ingestion, and API authorization aren’t affected.
Posted Feb 27, 2026 - 12:14 UTC
This scheduled maintenance affected: Dashboard + Config API and Staging System.