DRMtoday Production: Increased error rate on License Delivery in EU regions

Incident Report for DRMtoday

Postmortem

A detailed Root Cause Analysis (RCA) is available for this incident and can be provided upon request. To obtain a copy, please submit a ticket via our helpdesk. The report includes an overview of the incident timeline, contributing factors, and the corrective measures implemented.

Posted Jun 26, 2025 - 11:27 UTC

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 22:12 UTC

Monitoring

Multiple faulty instances were replaced and our services no longer show excessive error rates. We are monitoring the situation.
Posted Jun 24, 2025 - 20:26 UTC

Investigating

We are currently investigating this issue.
Posted Jun 24, 2025 - 19:45 UTC
This incident affected: License Delivery.