Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 26, 2024 - 18:30 UTC
Scheduled
The TLS certificates used to secure DRMtoday's publicly available endpoints will be updated. The renewed certificates will have the exact same certification path as the current ones.
No downtime anticipated.
Posted Nov 22, 2024 - 20:47 UTC
This scheduled maintenance affected: License Delivery, Key Ingestion, Dashboard + Config API, License delivery log + Reporting API, and Authentication.